Namen in Excel vergeben und in Formeln verwenden – So gehen Sie Schritt für Schritt vor

Titelbild das verwenden von Namen

Zellbezeichnungen wie C4 oder E12 sind nicht wirklich vielsagend. Aus diesem Grund haben Sie die Möglichkeit, im Tabellenkalkulationsprogramm Microsoft Excel Namen für Zellen zu vergeben. So können Sie verschiedene Zellinhalte schnell und unkompliziert mit den von Ihnen vergebenen Namen ansprechen sowie komplexe Formeln wesentlich einfacher verstehen und verwalten. Wir zeigen Ihnen, wie Sie hierbei Schritt für Schritt vorgehen.

Vergeben und Definieren von Namen

a) Excel-Namen vergeben

Namen in Excel zu vergeben, ist grundsätzlich ganz leicht und funktioniert mit nur wenigen Mausklicks. In unserem Beispiel vergeben wir für die Zelle B1 den Namen „mwst“. Diesen können wir später benutzen, um unterschiedlichste Excel-Formeln zu berechnen.

So gehen Sie vor, um im Tabellenkalkulationsprogramm Excel Namen zu definieren:

  1. Wählen Sie eine beliebige Zelle an, die Sie mit einem Namen versehen möchten.
  2. Geben Sie anschließend im Excel-Namensfeld Ihren gewünschten Namen ein. Dieses befindet sich links oben über Spalte A. In unserem Fall tippen wir hier „mwst“ ein.
namen definieren
  1. Bestätigen Sie Ihren Excel-Namen mit der ENTER-Taste.

Alternativ können Sie auch unter der Registerkarte „Formeln“ im Bereich „Definierte Namen“ auf die Schaltfläche „Namen definieren“ klicken. Es öffnet sich ein Dialogfenster, in dem Sie unter „Name“ ebenfalls Ihre gewünschte Zellbezeichnung eingeben können. Bestätigen Sie anschließend mit „OK“.

namen definieren über dialogfenster

Jetzt können Sie Ihren vergebenen Excel-Namen nach Belieben zum Rechnen mit verschiedenen Formeln verwenden.

Kurzer Exkurs: Wichtige Regeln bei Excel-Namen

Wenn Sie eine Zelle in Excel mit einem Namen versehen wollen, dann beachten Sie Folgendes:

Ein Name darf…

  • maximal 255 Zeichen lang sein
  • Buchstaben, Zahlen, Unterstriche und Punkte enthalten
  • mit Buchstaben oder einem Unterstrich beginnen

Nicht erlaubt sind:

  • Bindestriche
  • Leerzeichen
  • Namen, die wie Zellbezüge aussehen (z. B. B1, E12)

b) Excel-Namen für Zellbereiche definieren

Sie haben ebenfalls die Möglichkeit, bestimmten Zellbereichen in Excel Namen zuzuweisen. Das ist besonders praktisch, wenn Sie mit komplexeren Formeln rechnen. Gehen Sie hierzu folgendermaßen vor:

  1. Wählen Sie den Bereich aus, den Sie benennen möchten. Achten Sie darauf, sowohl die Zeilen- als auch die zugehörige Spaltenbeschriftung mit auszuwählen.
  2. Klicken Sie als nächstes unter der Registerkarte „Formeln“ im Bereich „Definierte Namen“ auf „Aus Auswahl erstellen“.
  3. Ein Dialogfenster öffnet sich. Hier haben Sie die Möglichkeit, ein oder mehrere Kontrollkästchen zu aktivieren. Entscheiden Sie sich entweder für die oberste Zeile, die linke Spalte, die unterste Zeile oder die rechte Spalte, um anzugeben, welche Beschriftung Sie ab sofort für den Namen verwenden möchten. Bestätigen Sie anschließend mit „OK“.
vergeben von namen für zellbereiche
  1. Ab sofort benennt Excel alle Zellen des ausgewählten Bereichs so, wie Sie angegeben haben.

Benannte Zellbereiche eignen sich zum Beispiel auch dann besonders gut, wenn Sie Formeln in Form von Parametern verwenden, die aus mehreren Zellen bestehen, wie zum Beispiel „SUMME(…)“.

Rechnen mit Namen

Sie müssen mit Excel häufiger komplizierte Kalkulationen erstellen bzw. sehen sich oft mit komplexen Formeln konfrontiert und tun sich schwer, den Überblick zu behalten? Wesentlich leichter funktioniert das Rechnen im Tabellenkalkulationsprogramm Excel mit vordefinierten Namen. So können Sie zum Beispiel die Formel zur Aufsummierung der regelmäßig anfallenden Steuern eines Unternehmens ganz simpel vereinfachen:

=SUMME(B2+B3+B4)

Komplizierter Weg unter Verwendung der ursprünglichen Excel-Zellbezeichnungen.

=SUMME(Steuern)

Hierzu müssen Sie für den Bereich B2 – B4 vorab natürlich den entsprechenden Namen vergeben (wie in unserem obigen Beispiel).

Verwenden von Namen in Funktionen am Beispiel SVERWEIS

Viel einfacher tun Sie sich ebenfalls, wenn Sie für SVERWEISE Excel-Namen vergeben. Vermutlich mag so gut wie niemand komplizierte SVERWEIS-Funktionen, die aus verschiedensten Zellbezügen und zahlreichen Dollarzeichen bestehen. Sie sind schwer zu lesen und zu übersetzen. Auch wenn sich mal versehentlich ein Fehler in einer Tabellenkalkulation einschleicht, ist dieser bei SVERWEISEN nicht immer leicht zu finden. Indem Sie in Excel Namen vergeben, können Sie SVERWEISE um einiges einfacher und übersichtlicher aufbauen:

SVERWEIS (G5; $ C$ 6: $ G $ 20;3; FALSCH)
SVERWEIS (Bilanz; Daten; 3; FALSCH)

Das ist mit Sicherheit für jeden wesentlich einfacher zu lesen. Was SVERWEISE sind und wie Sie sie verwenden, können Sie in unserem Beitrag „Excel SVERWEIS einfach erklärt“ nachlesen.

Der Excel Namensmanager

Sie können alle in einer Arbeitsmappe definierten Excel-Namen mit ihren Bezügen in einem Tabellenblatt als Liste ausgeben. Klicken Sie hierzu unter der Registerkarte „Formeln“ im Bereich „Definierte Namen“ auf die Schaltfläche „Namensmanager“.

liste definierte namen

Ein Dialogfenster öffnet sich, in dem Sie nun bequem alle Namen einsehen können, die Sie in Ihrer Arbeitsmappe verwenden. Sie haben darüber hinaus die Möglichkeit, im Namensmanager Namen zu erstellen, zu bearbeiten, zu löschen und zu suchen.

Fazit

Mit Excel haben Sie die Möglichkeit, Namen für folgende Elemente zu definieren:

  • Konstanten
  • Tabellen
  • Zellbereiche
  • Funktionen

Sobald Sie in einer Excel-Arbeitsmappe bestimmte Namen verwenden, können Sie diese jederzeit unkompliziert aktualisieren, ändern, überwachen und verwalten. Das hilft Ihnen dabei, sich bei Kalkulationen und komplexen Formeln besser zurechtzufinden und Sie profitieren von einer wesentlich besseren Übersichtlichkeit in Ihren Arbeitsmappen.

Ihr Seminaranbieter

AS Computertraining München Logo

Tel.: +49 (0) 89 45 06 63 16
E-Mail: training@as-computer.de

AS Computertraining ist seit über 25 Jahren für Kunden aus München und ganz Deutschland Ansprechpartner im Bereich IT Schulungen, Projektmanagement und Soft Skills.

Empfohlen

Excel Kurse

Excel Kurse
Excel Kurse für Anfänger oder Fortgeschrittene.

Weitere Beiträge

Monatlich Tipps & Tricks direkt via Mail

Bleiben Sie mit neuen und innovativen Tipps immer einen Schritt voraus.

Excel Kurse

Excel Kurse für Anfänger oder Fortgeschrittene.